Disappearing, altered and skewed dimension lines

  • December 15, 2017 at 4:47 pm #164281
    Tiffany Gadway

    When I save, close and re-open files, my dimension lines are altered, causing the need to adjust all of them back to the way they are supposed to be.

    Extension lines previously set to where I want them are then super long, stretching across my whole floorplan or elevation. Some new dimensions are added, running on a diagonal, to items that were never dimensioned before, or some of them are just plain missing, causing a lot of re-work with every file I open and close. Elevations do this worse than floorplans, but happens in both.

    Why does this happen and what can I do to make them save, open and close as they were drawn to be?

  • December 18, 2017 at 4:51 pm #164411
    Tiffany Gadway

    No feedback on this issue?

    I could really use an answer to avoid re-doing work with every file I close and open.


  • December 18, 2017 at 6:33 pm #164417

    Hi Tiffany,

    In the absence of an official response all I can say is that I have noticed this behaviour from time to time from V9 onwards but it has never presented as a major issue as it doesn’t always happen for me.

    Have you tried a registry reset? This will require you to redo all your preferences but is the first thing I would try.

    Also, I find that the default Display Settings can present a confusing amount of measurements so I tend to set these up with the minimum amount of automatic measurements and then save this back as a default. I then add manual measurements in wherever neededed and these do not seem to change (or at least rarely). The Display Settings schemes are very powerful and well worth learning how to use. With a few different display schemes stored, it only takes a few clicks to select the best scheme for any particular design.

  • December 19, 2017 at 11:26 am #164437
    Tiffany Gadway

    Hi, Mike. thanks for tip…I have not tried a registry reset. Really, I’m not positive how to do that, but I suppose I will look into it when I have time…maybe after I fix all my files upon opening today. 🙂 We did a company wide upgrade about 2 weeks ago to 11-whatever the most recent version is, but this was an issue that existed before that and continues since, maybe even slightly worse than prior to the upgrade.

    I am quite proficient with the Display Settings and wish it were more extensive, actually – I only use User Dimensions as I, too, find the auto option too broad and excessive when working on detail plans. My issue is specifically with user dimensions and have this issue regardless if a scheme is applied or not. I’ve tried both ways. I guess I will explore this registry reset you speak of….

    thanks for the input, Mike

  • December 19, 2017 at 6:11 pm #164470

    Hi Tiffany, Sorry to hear that your problems exist with the user dimensions. I work with about 30 designers and it hasn’t really been a reported issue by them so I’m not sure if they have the issue and aren’t reporting it or just don’t have the issue at all – I’ll solicit some responses from them.

    The registry reset is a 10 second job and useful for fixing a lot of hiccups that can arise. The only issue is that it sets all your preferences back to default so you have to go in and set them all up again. I recommend that before you do the registry reset, try screencapping all the different preference ‘pages’ and copy them into a Word Document as a reference for when you are re-entering them. I also have a registry and settings saver script which does this automatically but I recommend that you do not use it until you have got everything working again.

    The registry reset is off the Start Menu (in Win7/8 and just All Programs in Win10) in All Programs/Design/Tools/Maintenance Tools. Pic attached.

    You can get my Settings Saver script here:

    Unzip it to the Desktop and you will see an icon labelled V112020SettingsSaver.cmd – double click it and follow the instructions. It creates a folder on your desktop called 2020RESCUE. I’ll have an example video uploaded shortly but it’s very simple.

    You must be logged in to view attached files.
  • December 21, 2017 at 3:11 pm #164692
    Tiffany Gadway

    Thank you so very much for the help, tips, screenshots and file, Mike….I have officially reset my registry and unfortunately, my issue continues. Sad face.

    Now I wonder if the issue is related to my settings that are set for dimension lines. In the settings options, there is just a box that you either check or uncheck for “long extension” lines. Checking the box allows you to adjust the length of the extension lines to any desired length, which I do. Depending on what I am detailing, sometimes I need them sort, other times longer to better illustrate the information, so I have them checked as long and adjust them individually. But upon opening a file, those carefully, manually adjusted extension lines are all just super long all over the place, if not missing the whole dimension completely.

    Maybe they just don’t work in 2020 the way I want them to and the way I have been accustomed to while working in AutoCAD? Can I not adjust them individually and have this saved? Is it all or nothing? Either all really short, or all really long? I would think they are able to be adjusted and saved that way, since it allows adjustments in the first place. I don’t know, but color me frustrated. 🙂 …a nice shade of green.

    (I’ve attached a screenshot of what I get after opening a file on the left, and how I need them to be on the right) This file isn’t so bad, but the more detailed the drawing, the more cumbersome this becomes.


    You must be logged in to view attached files.
  • December 21, 2017 at 6:33 pm #164741

    Well, I’m at a loss other than suggesting a complete uninstall and reinstall. Ive added user dimensions (in Maroon) to Floorplan, Elevation and Benchtop Layout with no issue – they come back EXACTLY where they were placed. I’m on V11.8.2.13

    You must be logged in to view attached files.
  • December 21, 2017 at 6:47 pm #164767
    Tiffany Gadway

    No, it is also in floorplans.

    For instance, I have a drawing that is a framing plan, it has 17 dimensions on it. Save, Close, Open, now it has 2. 15 of 17 are missing. Asked my boss about the issue, he said, it always does that. Told me to turn off user dimensions, apply it, turn them back on and apply it…and maybe they would come back, if I get lucky…. Did that, but nope. Still just 2 of 17. He says that trick works for him a lot…doesn’t work for me. He says this has been an issue for as long as he has used the software, which is years and years….

    80% of my work involves dimensioning things for installation, so its a pretty big deal. My efficiency is out the window.

    I appreciate your effort and feedback, Mike! 🙂

  • December 21, 2017 at 7:44 pm #164768

    Sorry Tiffany I just don’t get that issue at all. I think it has to be back to 2020 Tech Support.

  • January 11, 2018 at 2:35 pm #166123
    2020 Expert

    Hello Tiffany

    Several issues with dimensions were addressed on previous builds, I am not certain why this keeps occurring on your system.

    We will contact you soon for a deeper verification.



You must be logged in to reply to this topic.

Topic Tags

Share this Post